Unable To Connect Social Media Accounts To Hearsay
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 05/04/23 9:20 AM PT

End Time: 05/04/23 10:36 AM PT

Customer Impact:

Hearsay made a change to the styles of our feedback modal which resulted in users experiencing a blank page when connecting their social media account to Hearsay. During this incident, users were unable to connect new social media accounts. Any social media accounts connected before this incident were not impacted and there was no data loss during this time.

Resolution:

Hearsay’s engineers repaired this matter by deploying an update to our infrastructure, which added more protection against this error.

Future Improvements:

Hearsay has proactive alerting mechanisms in place, which assisted us in identifying and responding to this incident promptly. To help prevent similar occurrences in the future, we plan to update our process to require quicker resolution deployments for issues picked up by alerting.

Posted May 11, 2023 - 13:25 PDT

Resolved
Hearsay’s engineers were able to resolve this incident, and users are now able to connect their social media accounts to the Hearsay platform. We will investigate this matter further to provide a post-mortem and will add it to this incident once we have all the necessary and relevant information. Again, we apologize for this disruption and want to thank you for your patience while we resolved this matter.
Posted May 04, 2023 - 10:40 PDT
Update
We are continuing to work to resolve this issue with connecting social media accounts to Hearsay. This is still our top priority, and we will have another update shortly. Thank you for your patience as we work to resolve this for you.
Posted May 04, 2023 - 10:36 PDT
Update
Hearsay’s engineers are still investigating this matter regarding the inability to connect new social media accounts to the Hearsay platform. We will provide another update shortly and want to thank you again for your patience.
Posted May 04, 2023 - 10:06 PDT
Investigating
We're currently experiencing an issue where users are unable to connect their social media accounts to Hearsay. Our engineers are currently investigating this matter, and we will provide an update shortly. We apologize for this disruption and greatly appreciate your patience while we work through this.
Posted May 04, 2023 - 09:34 PDT
This incident affected: Social.