Linkedin Image Publishing Issue
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 07/11/2023 1:16 PM PT

End Time: 07/11/2023 2:38 PM PT

Customer Impact:

A recent code deployment led to image-only posts failing to publish to LinkedIn for both scheduled and newly created posts. During this incident, users would have seen these failed posts in their Post Library under the “Published” tab as failed.

Resolution:

Hearsay’s engineers quickly reverted back to a previous version of our code base to ensure image-only posts publish successfully to LinkedIn.

Future Improvements:

Hearsay has already begun restructuring our automated alerting for errors. We are also creating more testing around this particular scenario to catch these instances before future production deployments.

Posted Aug 01, 2023 - 09:55 PDT

Resolved
Hearsay Engineers have resolved the ongoing issue with publishing image-only posts to Linkedin. We would like to express our sincere apologies for any inconvenience caused by the recent disruption. We will be posting a full post-mortem on the incident with additional details on the issue and how it can be avoided in the future. We greatly appreciate your patience and understanding as we worked to resolve this issue.
Posted Jul 11, 2023 - 14:43 PDT
Update
Hearsay continues actively investigating an issue where image-only posts fail to publish to Linkedin. Hearsay's engineers are actively looking into this matter and are treating this as our top priority. We truly apologize for any disruption and will provide an update shortly.
Posted Jul 11, 2023 - 14:28 PDT
Investigating
Hearsay is actively investigating an issue where image-only posts are failing to publish to Linkedin. Hearsay's engineers are actively looking into this matter and are treating this as our top priority. We truly apologize for any disruption and will provide an update shortly.
Posted Jul 11, 2023 - 13:52 PDT
This incident affected: Social.