Blank Screen For Some Relate Users
Incident Report for Hearsay Systems
Postmortem

Timeline:
Start Time: 08/28/2024 10:18 AM PT
End Time:: 08/28/2024 12:12 PM PT

Customer Impact:
On August 28th at 10:00 AM PT, Hearsay deployed a system code upgrade that affected the ability of a small set of users to access the Hearsay Relate web app. Relate on Hearsay Mobile was not affected. Messages received during this time were not impacted and remain available on all platforms.

Resolution:
Hearsay's engineers quickly rolled back to a recent release and ensured there was no loss of data.

Future Improvements:
Hearsay's engineers have identified the source of the issue, made code changes to address these, and further hardened surrounding areas of code. Additional software tests have been made to ensure stability.

Posted Aug 30, 2024 - 10:47 PDT

Resolved
Hearsay’s engineers have successfully resolved this incident, and the subset of users who experienced a blank screen should now see their conversations on our website. Thank you for your patience. After a full investigation, we will provide a post-mortem.
Posted Aug 28, 2024 - 12:22 PDT
Identified
Hearsay is aware of a current incident where some Relate users may see a blank screen when accessing their conversations on our desktop/web platform. Our engineers have pinpointed the root cause and are working to deploy a fix as soon as possible. Please note that this is not happening for all users on Hearsay Relate. We apologize for this disruption and will have another update shortly.
Posted Aug 28, 2024 - 12:11 PDT
This incident affected: Relate.