Android Users Unable to Log In to the Hearsay Mobile App

Incident Report for Hearsay Systems

Postmortem

Timeline:

Start Time: 03/14/2025 6:53 AM PT

End Time: 03/14/2025 8:19 AM PT

Customer Impact:

Android users were unable to log in to the mobile app, receiving an error message prompting them to "Please try again." The root cause was due to a recent version upgrade of an internet protocol. Hearsay’s Android app was configured for the earlier version, which caused the error message to occur. During this incident, there was no data loss.

Resolution:

Hearsay’s engineers promptly identified the cause and quickly reverted to the previous version. Once reverted, service was restored for Android users.

Future Improvements:

To prevent this type of issue from happening in the future, we are improving our internal processes to ensure thorough testing and validation before updates are released. This includes better detection and handling of any potential impacts from future security updates.

Posted Mar 19, 2025 - 06:21 PDT

Resolved

Hearsay resolved this matter, and we have confirmed that Android users can log in and use the Hearsay mobile app. After conducting a thorough investigation, we will provide a post-mortem summary of this incident. We apologize for any disruption this might have caused.
Posted Mar 14, 2025 - 07:16 PDT

Investigating

Hearsay is currently investigating a matter where Android users may not be able to log in to the Hearsay mobile application. Our engineers are working to solve this as quickly as possible. Please note that iPhone users, as well as our desktop platform, are working as expected.
Posted Mar 14, 2025 - 07:00 PDT
This incident affected: Platform.