New Post Button Missing For The Content Creator Role
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 05/16/2023 8:38 AM PT

End Time: 05/16/2023 11:21 AM PT

Customer Impact:

Due to a code deployment, some admins with the Creator Content role inside Hearsay were unable to use the Suggested Post Library page, and some admins were unable to create a new post when they had the correct privileges.

Resolution:

Engineers made updates to the Creator Content role to resolve this matter. This new code was reviewed and tested by several engineers to ensure we solve this edge case.

Future Improvements:

This edge case’s current behavior has been fully documented, which will allow Hearsay’s engineers to create automated tests to catch this before any future production deployments.

Posted Jun 07, 2023 - 07:37 PDT

Resolved
Hearsay's engineers deployed a fix to production and we are able to verify that this incident is fully resolved and the New Post button is appearing for the Content Creator role. We are committed to conducting a thorough investigation into this matter and will provide a post-mortem to this incident. Your patience during this process is genuinely valued, and we deeply apologize for any inconvenience this may have caused you. We extend our sincere gratitude for your understanding and cooperation. Thank you sincerely for your support.
Posted May 16, 2023 - 11:20 PDT
Update
Hearsay is fully engaged in deploying fixes for both scenarios, and we are making significant progress. This matter is still our top priority and we will share another update shortly. Your patience and understanding are immensely valued during this process, and we wholeheartedly appreciate your unwavering support throughout this process.
Posted May 16, 2023 - 11:12 PDT
Update
Hearsay's engineers continue to actively work on implementing a permanent solution for both cases, and we will update this incident very soon as we work through this. We greatly appreciate your patience and understanding.
Posted May 16, 2023 - 10:34 PDT
Identified
Hearsay's engineers have identified the root cause for both issues regarding a missing New Post button and some users not seeing Suggested Posts. We will share another update shortly. Again, thank you for your patience while we resolve this matter for you.
Posted May 16, 2023 - 10:01 PDT
Investigating
Hearsay is currently investigating a matter relating to the New Post button not appearing, and for some users, not being able to see Suggested Posts. This is only affecting any Hearsay users who are assigned the Content Creator role. We truly apologize for this incident and our engineers are working hard to resolve this as this is our top priority. We will provide another update shortly, and thank you for your patience as we look into this.
Posted May 16, 2023 - 09:25 PDT
This incident affected: Social.