Internal Server Error when accessing Relate

Incident Report for Hearsay Systems

Postmortem

Timeline:

Start Time: 04/15/2025 3:19 PM PT

End Time: 04/15/2025 4:05 PM PT

Customer Impact:

Users interfacing with Hearsay Relate via web, mobile app, and Embedded Relate with Salesforce may have experienced slower-than-normal page loading times or error messages during this incident. This was due to an unexpected high number of API requests to a specific endpoint, which resulted in an inefficient query pattern that caused a slowdown in our database systems. There was no data loss during this incident.

Resolution:

Yext’s engineers quickly identified the source of the problem and temporarily reduced the throughput for this specific operation to allow the database to recover. This restored performance for all users.

Future Improvements:

Yext is already in the process of implementing rate limiting on all public APIs, and continuing to enhance our monitoring systems to detect unusual database patterns earlier.

Posted Apr 23, 2025 - 13:21 PDT

Resolved

Hearsay's engineering team was able to address the capacity issue causing the reported degraded performance. We sincerely apologize for any disruption to your teams.
Posted Apr 15, 2025 - 16:29 PDT

Investigating

Hearsay is currently investigating an incident where our platform is experiencing a delay, blank screen, or Internal Server Errors when accessing Relate. We are treating this with the utmost priority and will share an update soon. We truly apologize for any disruption to your business.
Posted Apr 15, 2025 - 16:03 PDT
This incident affected: Relate.