Content approved in Supervision not updated in the Content Library

Incident Report for Hearsay Systems

Postmortem

From June 11 2025, 9:35 UTC - June 11 2025 22:10 UTC, customers using Social and Mail products with compliance features enabled experienced delays in seeing their approved suggested content appear in the Suggested Content Library. This was due to a temporary slowdown in our system that was caused by a backed up queue.

Timeline:

Start Time: June 11, 2025 9:35 UTC

End Time: June 11 2025 22:11 UTC

Customer Impact:

  • All Social and Mail customers with Compliance enabled were affected by this issue. These customers experienced delays in approved suggested content being posted to their Suggested Content Library due to a backed-up queue.
  • There was no data loss or corruption. All content remained intact, and the delayed items were successfully delivered once the queue was processed.

Root Cause:

  • The issue was caused by a backlog in the processing queue, which temporarily slowed down the flow of suggested content into the library.

Resolution:

  • Additional infrastructure components were added temporarily to process the queue and resolve the backlog.

Future Improvements:

  • We are implementing additional monitoring on SQS queue around age and volume of messages in queues.
  • Monitor tasks running in high-priority queues for timely completion.
Posted Jun 26, 2025 - 11:32 PDT

Resolved

There was delay in processing suggested content approvals. All outstanding tasks have been completed and statuses now reflect correctly in the content library. This incident is resolved.
Posted Jun 11, 2025 - 15:43 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 15:19 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2025 - 13:33 PDT

Investigating

We are currently investigating reports of Content approved in Supervision not updated in the content library, resulting in content that is approved in supervision not showing up in an end user's library.
Posted Jun 11, 2025 - 13:13 PDT
This incident affected: Compliance and Social.