LinkedIn Cover Photo Issue

Incident Report for Hearsay Systems

Postmortem

Timeline:
Start Time: 06/25/2024 5:00 PM PT
End Time: 07/02/2024 06:30 AM PT

Customer Impact:
On June 25th, Hearsay enabled a new LinkedIn cover photo field. The field was enabled unintentionally for all organizations, which generated an influx of profile alerts. This affected LinkedIn profiles with existing cover photos.

Some users encountered issues where profiles remained in an "action required" status due to upload issues.

Resolution:
Hearsay provided guidance to administrators on how to disable the LinkedIn Cover photo field in the administrator settings if they prefer not to supervise the field. Turning off the field in administrator settings would move the affected profiles back to an approved state. Hearsay also provided the option to bulk dismiss alerts upon request.

LinkedIn began using a different profile picture upload URL in some cases, for which the existing current profile integration was not prepared. The uploading issues occurred due to an unannounced change made by LinkedIn. Our engineers deployed an update to our legacy systems to handle LinkedIn URLs that differ from the usual ones.

Future Improvements:
Our engineering team will continue to assess and address the impacts of introducing new profile fields.

Posted Jul 24, 2024 - 12:49 PDT

Resolved

Network: LinkedIn

Date Discovered: June 28, 2024

Date Fixed: July 2, 2024


Background: Hearsay enabled a new feature that allows all organizations to set a LinkedIn cover photo. It was later discovered that LinkedIn made an unannounced change and began using different profile and cover photo upload URLs in some instances, which caused some user profiles to remain in ‘action required’ status.

Also, since this new feature was enabled by default, it generated an influx of profile alerts for cover photos.

Resolution: Hearsay rolled out a fix that updated its legacy integration to handle this change. Profiles are no longer stuck in ‘action required’ status.

Next steps/Recommend actions: Hearsay can bulk dismiss the alerts that were generated by this new feature. Please reach out to your Support or Success team for this request.
Posted Jun 27, 2024 - 21:00 PDT