Videos Unable To Publish To LinkedIn
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 05/15/23 5:07 AM PT

End Time: 05/15/23 8:10 AM PT

Customer Impact:

Hearsay deployed an update, as per the recommendation of LinkedIn’s developers, to add polling checks to obtain the status of any processing posts. This check would inform Hearsay’s users if their LinkedIn posts were successful or failed to publish. Implementing these additional checks caused Hearsay to hit our rate limit with LinkedIn, specifically for publishing videos via LinkedIn’s API. This resulted in Hearsay’s users being temporarily unable to publish videos to LinkedIn.

Resolution:

Our partners at LinkedIn reset our rate limit for the day, resulting in more bandwidth to publish videos successfully to LinkedIn.

Future Improvements:

Hearsay has already added a maximum number of attempts to the polling checks to prevent this from reoccurring. Additionally, Hearsay is actively working with LinkedIn to discuss our API usage to ensure we continue to have ample bandwidth.

Posted May 23, 2023 - 09:46 PDT

Resolved
Hearsay's engineers worked with LinkedIn to resolve this matter, resulting in videos successfully published to LinkedIn. We will investigate this matter further and provide a post-mortem to this incident. We sincerely appreciate your patience as we worked through this incident and we truly apologize for any disruption to your day. Thank you so much.
Posted May 15, 2023 - 08:18 PDT
Update
The incident regarding LinkedIn video posts is still under investigation and we are actively working on resolving it. Rest assured, all other publishing features on LinkedIn are fully operational, and users can still share videos on other social media platforms successfully.

We understand that this situation can be frustrating, and we truly appreciate your patience as we navigate through this matter. We assure you that we are doing everything possible to resolve this issue as soon as possible and will keep you updated every step of the way. Thank you for your understanding.
Posted May 15, 2023 - 07:35 PDT
Update
This matter pertaining to LinkedIn video posts is still ongoing. All other publishing capabilities are still functional on LinkedIn, and video publishing is available on other social media platforms. Thank you so much for your patience while we resolve this matter for you.
Posted May 15, 2023 - 07:00 PDT
Update
This incident involving unsuccessful LinkedIn video posts remains open, and we are eagerly awaiting a response from our LinkedIn partners. It's important to mention that users can still publish videos to alternative social media platforms, while also being able to publish text and images on LinkedIn without any issues. We genuinely appreciate your patience as we continue to address this matter for you.
Posted May 15, 2023 - 06:28 PDT
Update
This matter regarding failed LinkedIn posts containing videos is still ongoing, and we are waiting to hear back from our partners at LinkedIn. Again, please note that users can still successfully publish videos to other social media platforms as well as text and images to LinkedIn. Thank you for your patience as we continue to work through this for you.
Posted May 15, 2023 - 05:55 PDT
Investigating
There's an incident where users are unable to publish videos to LinkedIn. This matter has already been escalated to LinkedIn, and we are actively monitoring this situation. Please note that users can still publish text and images to LinkedIn successfully as well as publish video to other social media platforms. We apologize for this disruption and will provide an update shortly.
Posted May 15, 2023 - 05:26 PDT
This incident affected: Social.