Images Unable To Publish To LinkedIn
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 5/12/23 6:50 AM PT

End Time: 5/12/23 7:45 AM PT

Customer Impact:

Hearsay deployed an update, as per the recommendation of LinkedIn’s developers, to add polling checks to obtain the status of any processing posts. This check would inform Hearsay’s users if their LinkedIn posts were successful or failed to publish. Implementing these additional checks caused Hearsay to hit our rate limit with LinkedIn, specifically for publishing images via LinkedIn’s API. This resulted in Hearsay’s users being temporarily unable to publish images to LinkedIn.

Resolution:

Hearsay’s engineers reverted the deployment, which removed the additional checks. Additionally, LinkedIn’s rate limit is on a rolling 24 hours, meaning we could provide a faster turnaround on a resolution.

Future Improvements:

Hearsay has already added a maximum number of attempts to the polling checks to prevent this from reoccurring. Additionally, Hearsay is actively working with LinkedIn to discuss our API usage to ensure we continue to have ample bandwidth.

Posted May 23, 2023 - 09:45 PDT

Resolved
After monitoring this incident for the past hour, we are continuing to see successful images published to LinkedIn. Hearsay's engineers will investigate this matter further and provide a post-mortem to this incident. We greatly appreciate your patience as we worked through this matter and sincerely apologize for any disruption to your day.
Posted May 12, 2023 - 09:11 PDT
Update
Hearsay is continuing to see images successfully published to LinkedIn. We will continue to monitor this over the next 30 minutes and provide an update to confirm if this incident is fully resolved. Thank you for your patience.
Posted May 12, 2023 - 08:38 PDT
Monitoring
Hearsay has begun to see images successfully published to LinkedIn. We will continue monitoring the progress to ensure everything works as expected. An update will be published shortly with a confirmation. We greatly appreciate your patience while we work through this incident.
Posted May 12, 2023 - 08:10 PDT
Update
This matter regarding failed LinkedIn posts containing images is still active, and we are waiting to hear back from our partners at LinkedIn. Again, please note that users can still successfully publish images to other social media platforms as well as text and videos to LinkedIn. Thank you so much for your patience as we continue to work through this for you.
Posted May 12, 2023 - 07:42 PDT
Identified
There's an incident where users are unable to publish images to LinkedIn. This matter has already been escalated to LinkedIn, and we are actively monitoring this situation. Please note that users can still publish text and videos to LinkedIn successfully as well as publish images to other social media platforms. We apologize for this disruption and will provide an update shortly.
Posted May 12, 2023 - 07:08 PDT
This incident affected: Social.