Internal Server Error when accessing Hearsay website

Incident Report for Hearsay Systems

Postmortem

Timeline:

Start Time: 05/08/25 2:48 PM PT

End Time: 05/08/25 3:08 PM PT

Customer Impact:

Customers who tried to access the Hearsay platform via desktop, mobile app, or Embedded Relate received an Internal Server Error. This was due to a database update, which caused longer page load times that resulted in the error.

Resolution:

Yext engineers identified the root cause and reverted to a previous state immediately, which restored services for all customers.

Future Improvements:

We have identified and are going to implement additional process improvements around deploying database changes, and add more automated validations based on the cause of the incident.

Posted May 15, 2025 - 06:22 PDT

Resolved

Hearsay's engineering team was able to address the issue preventing the site from loading. We sincerely apologize for any disruption to your teams.
Posted May 08, 2025 - 15:13 PDT

Investigating

Hearsay is currently investigating an incident in which users get an Internal Server Error when accessing the site. We are treating this as our top priority and will share an update soon. We truly apologize for any disruption to your business.
Posted May 08, 2025 - 15:01 PDT
This incident affected: Platform.