Users Unable To Publish Content To LinkedIn
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 10/26/23 1:00 AM PT

End Time: 10/26/23 11:58 AM PT

 

Customer Impact:

Customers saw a spinning wheel when attempting to publish content to LinkedIn. These posts were not failing, but rather, LinkedIn posts were delayed in publishing. This was due to an influx of large video files attempting to publish to LinkedIn at the same time. All other social media networks were publishing content as expected.

 

Resolution:

Hearsay’s engineers temporarily increased bandwidth to work around the larger video files, which added more resourcing power to allow us to speed through the queue.

 

Future Improvements:

Hearsay is currently looking at refining our video upload requirements for LinkedIn, specifically video length. We are also exploring adding more internal alerting to proactively get ahead of queues facing a longer-than-expected publishing time.

Posted Nov 09, 2023 - 09:32 PST

Resolved
Hearsay's engineers have confirmed that users should no longer experience this matter where posts are unable to publish from Hearsay to LinkedIn. We truly apologize for this disruption. Once we complete a thorough investigation, we will publish a post-mortem to this incident.
Posted Oct 26, 2023 - 12:28 PDT
Identified
Hearsay’s engineers have identified the root cause due to an influx of publishing content with large video files. We are in the process of expiring related content materials that may cause further publishing delays in Hearsay. Please note that all other social media platforms are working as expected. Thank you for your patience as we continue to work on this matter.
Posted Oct 26, 2023 - 11:47 PDT
Update
Hearsay's engineers are still investigating this incident where users are unable to publish content to LinkedIn. All other social media networks are fully operational. We will provide another update shortly and hope to resolve this as soon as possible.
Posted Oct 26, 2023 - 10:42 PDT
Investigating
Hearsay is currently experiencing an issue where social media posts are unable to publish to LinkedIn successfully. This has been raised to our engineering team to determine the root cause so we can implement a resolution. Please note that all other social media platforms are working as expected. Thank you for your patience as we investigate this matter.
Posted Oct 26, 2023 - 10:06 PDT
This incident affected: Social.