Unable to Post Content to Twitter
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 07/09/23 5:49 PM PT

End Time: 07/11/23 8:06 AM PT

Customer Impact:

Users experienced difficulty with Twitter, now operating as X, specifically publishing posts and crawling failed during this timeframe. This incident was due to an outage at Twitter that impacted a number of their customer enterprise integrations.

Resolution:

Hearsay’s alerting system notified our engineers about the issue, which we promptly escalated to our developer partners at Twitter. After Twitter notified us that they fixed the issue on their side, Hearsay checked and confirmed that users were able to successfully publish to the platform via Hearsay.

Future Improvements:

Although the root cause was an internal outage at Twitter, we will continue to maintain our robust alerting system to catch similar issues in the future.

Posted Aug 17, 2023 - 13:44 PDT

Resolved
Hearsay’s engineers confirm that the Twitter content publishing issue is now resolved. We truly apologize for this disruption and will publish a post-mortem after completing a full investigation. Thank you so much for your patience and understanding.
Posted Jul 11, 2023 - 11:25 PDT
Monitoring
Hearsay’s engineers confirm that the Twitter content publishing is now working properly. We are continuously testing and will monitor to confirm the fix. We sincerely apologize for any disruption to your business, and we will provide an update once we have more information.
Posted Jul 11, 2023 - 09:25 PDT
Update
Hearsay is continuing to investigate this matter where users cannot post content to Twitter and we are treating this as our top priority. We will continue to provide updates on this incident until it is fully resolved. Thank you so much for your patience.
Posted Jul 11, 2023 - 07:33 PDT
Investigating
Hearsay's engineers are investigating an issue where users cannot post content to Twitter. Rest assured, we are actively working on this matter and have contacted our partners at Twitter. It is important to note that all other social media networks are fully operational. We sincerely apologize for any disruption to your business, and we will provide an update once we have more information.
Posted Jul 11, 2023 - 04:51 PDT
This incident affected: Social.