"Something Went Wrong" Error Page
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 01/25/2024 01:44 PM PT

End Time: 01/25/2024 02:48 PM PT

Customer Impact:

Hearsay’s engineers made an update to how users can search for phone numbers, and this specific index was not reindexed prior to the production deployment, resulting in unavailability across our platform.

Resolution:

Engineers reverted back to a previous version of the feature flag that contained this index and have since reindexed any missing indices.

Future Improvements:

Hearsay will improve our approach to production deployments that contain feature flags, specifically investigating how we can implement a slower, phased rollout. Hearsay’s engineers will also invest in more production-like load testing environments to catch future edge cases.

Posted Feb 01, 2024 - 09:00 PST

Resolved
Hearsay's engineers resolved the site error issue. Again, we truly apologize for this disruption and we will publish a post-mortem after we complete a full investigation. Thank you so much for your patience and understanding.
Posted Jan 25, 2024 - 14:46 PST
Investigating
Hearsay is currently experiencing an issue where our website fails to load and gives out "Something Went Wrong" error. We are actively looking into this matter and are treating this as our top priority. We will provide an update shortly.
Posted Jan 25, 2024 - 14:07 PST
This incident affected: Platform.