Intermittent Error Page
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 02/13/23 11:40 AM PT

End Time: 02/13/23 12:04 PM PT

Customer Impact:

A production update to one of Hearsay's services caused slowness on our website and for some users to experience an error page. This was due to a needed Cryptography security update that proved incompatible with another OpenSSL component.

Resolution:

Services were quickly rolled back to a stable version of both dependencies and all services quickly stabilized.

Future Improvements:

Hearsay will add increased automated checks to ensure ongoing component compatibility of these security updates.

Posted Feb 21, 2023 - 13:44 PST

Resolved
Hearsay's engineers were able to successfully resolve this intermittent error. Again, we truly apologize for this matter and we will publish a post-mortem after we complete a full investigation. Thank you so much for your patience and understanding.
Posted Feb 13, 2023 - 12:06 PST
Investigating
We are currently experiencing an intermittent matter where some users are seeing an error page. Hearsay's engineers are investigating this now and will provide an update as soon as we have more information. Please know this is our top priority and we truly apologize for this disruption.
Posted Feb 13, 2023 - 11:53 PST
This incident affected: Platform.