Publishing Errors for X

Incident Report for Hearsay Systems

Postmortem

Timeline:

Start Time: 11/11/24 7:45 AM PT

End Time: 11/11/24 12:05 PM PT

Customer Impact:

Publishing content from Hearsay to X, formerly known as Twitter, was temporarily unavailable. This was due to the Hearsay application reaching an undocumented API rate limit that X has in place.

Resolution:

Hearsay divided the scheduled posts to mitigate the amount of payload that X was able to handle.

Future Improvements:

Hearsay will improve our publishing system to detect and handle these situations in the future without any major disruption in immediate publishing. Hearsay has also begun working with X on improving rate limit documentation and awareness for their public APIs.

Posted Nov 21, 2024 - 10:24 PST

Resolved

Hearsay engineers confirmed the X publishing error has been resolved. Failed scheduled posts will be retried automatically in the next few hours; please republish manually initiated real-time posts. A post-mortem will be published after we complete a thorough investigation, we truly appreciate your patience as we worked to resolve this issue.
Posted Nov 11, 2024 - 12:23 PST

Identified

Hearsay engineers have identified the root cause and are working on fixing the publishing issues to X. We will share another update shortly. Again, thank you for your patience while we resolve this for you.
Posted Nov 11, 2024 - 11:15 PST

Update

Hearsay Engineers continue to actively investigate the publishing issue to X and are treating this as our top priority. We truly apologize for any disruption and will provide an update shortly.
Posted Nov 11, 2024 - 08:29 PST

Investigating

Hearsay is currently experiencing an incident where users may run into an error when publishing content to X, formerly known as Twitter. Hearsay's engineers are actively troubleshooting this and treating it as our top priority. We will update this incident once we have more information from our engineers.
Posted Nov 11, 2024 - 07:58 PST
This incident affected: Social.