Relate Messages Not Appearing In Web UI

Incident Report for Hearsay Systems

Postmortem

Timeline:

Start Time: April 9, 2025 11:11 AM PT

End Time: April 9, 2025 12:42 PM PT

Customer Impact:

Users on Hearsay’s web version of Relate who refreshed their browser during the incident window (the “Timeline” period identified above) would have temporarily experienced a problem where they could not see their conversation messages. This incident did not impact users utilizing our mobile app, Embedded Relate for Salesforce, or if they did not refresh their web browser during this timeframe. This was caused by a recent code deployment to update our front-end web components. There was no data loss during this incident.

Resolution:

The previously mentioned code deployment was reverted to a previous version, which brought back the ability to view all conversations in the web version of Relate.

Future Improvements:

To ensure a seamless user experience and prevent similar issues from occurring in the future, we will be implementing additional testing and enhanced quality checks focused on the proper loading of user messages.

Posted Apr 14, 2025 - 13:52 PDT

Resolved

Hearsay's engineering team was able to revert to a previous version and resolve this incident. Once they refresh their browser, users can see all the messages in our website interface. We truly apologize for any disruption to your teams, and we will provide a root cause analysis once an investigation has been completed.
Posted Apr 09, 2025 - 12:45 PDT

Investigating

Hearsay is experiencing an incident where Relate messages in our website interface may show a blank conversation. At this moment, this is only impacting our Hearsay website, as our mobile app and Embedded Relate with Salesforce are working as expected. Users are still able to send text messages, which may temporarily cause the conversation thread to reappear, but they may disappear after refreshing the browser or navigating to another conversation. Our engineers are treating this as our top priority and will provide an update shortly.
Posted Apr 09, 2025 - 12:38 PDT
This incident affected: Relate.