Relate Error Page
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 09/18/2024 11:10 AM PT

End Time: 09/18/2024 11:28 PM PT

Customer Impact:

On September 18th at around 11:00 AM PT, Hearsay deployed a new feature which inadvertently contained a code that prevented users from loading application configurations on the Relate web app. Hearsay Relate on mobile application was not affected. All functionality was restored and there were no data loss as a result of this incident.

Resolution:

Hearsay's engineers identified the error and reverted back the change.

Future Improvements:

Hearsay will add additional alarms specific to the endpoint for faster resolution times. Additionally, Hearsay's engineers will avoid making similar changes during, or close to, business hours.

Posted Oct 02, 2024 - 15:20 PDT

Resolved
Hearsay's engineers were able to quickly revert to a previous version, and Relate is working as expected on our website. After conducting a formal investigation, we will publish a post-mortem to this incident. We truly apologize for the disruption.
Posted Sep 18, 2024 - 11:29 PDT
Investigating
Hearsay is currently experiencing an incident where Relate users on desktop may see an error, "Something went wrong. Please refresh the page to try again." Hearsay's mobile app is still functioning as expected. Please know that Hearsay's engineers are treating this as our top priority to ensure a quick resolution.
Posted Sep 18, 2024 - 11:26 PDT
This incident affected: Relate.