Campaign Management Loading Issue
Incident Report for Hearsay Systems
Postmortem

Timeline:

Start Time: 9/14/23 5:37 AM PT

End Time: 9/14/23 12:34 PM PT

Customer Impact:

If any organization admins attempted to edit a campaign, they would encounter a blank page. This occurred due to Hearsay’s engineers attempting to fix a minor bug in the campaign editor.

Resolution:

Hearsay’s engineers reverted our code to a previous version, which allowed admins to edit campaigns.

Future Improvements:

Additional tests have been added to our deployment process to make sure that this specific incident does not reoccur.

Posted Nov 21, 2023 - 09:53 PST

Resolved
Hearsay Engineers have resolved the ongoing issue. We would like to express our sincere apologies for any inconvenience caused by the recent disruption. We will be posting a full post-mortem on the incident with additional details on the issue and how it can be avoided in the future. We greatly appreciate your patience and understanding as we worked to resolve this issue.
Posted Sep 14, 2023 - 12:37 PDT
Identified
Hearsay Engineers have identified the cause of the issue and are working quickly on a resolution. Once we have confirmation of the issue being fully resolved, we will provide another update here. Thank you for your patience.
Posted Sep 14, 2023 - 12:29 PDT
Investigating
Hearsay is currently experiencing an issue with campaign management. When selecting a campaign for editing, users encounter a blank page. Hearsay is currently investigating this matter, and we are treating this as our top priority. We will provide frequent updates until this is fully resolved. We truly apologize for this matter and greatly appreciate your understanding and patience.
Posted Sep 14, 2023 - 12:24 PDT
This incident affected: Social.